Problem with sync to remote host

So I now finally gave my buddy box (which was running fine in my local network for weeks) to my brother.

I set up port forwarding for his box in his network. He has a dyndns address via I can successfully ssh to from my syncosync box to his (but not login with password of course). So I think everything is set up correctly.

Still, my syncosync box, using that address in the synch configuration, continues to show an “issue with remote host” icon. Even after a reboot.

On his side everything works fine (green icon). I use another dyndns provider.

I even restarted the key exchange, and that worked fine (with him leading).

What could be the problem? Where can I possibly find information on what is going wrong?

Ok, it is definitely a problem with DNS resolution. When I put the IPv4 address, synch works fine and icon becomes green. When I put back the address, synch icon becomes red again.

But the name resolution should work just fine. I can ping and ssh to that address from the command-line of my syncosync box.

Please advise what I can do to check/fix this!

that sound really strange.
All UI action - and even more - is possible via command line:
After you have configured the remote host, you can check with:
sudo -v DEBUG -c
what is happening… -h
gives you all possible actions…

As almost every sos admin action needs root privileges, I do all this while being root on the syncosync box.

I think I will put an auto generated command line reference in the manual, could be a nice hack anyways :slight_smile:

Thanks for your quick reply, I get:

sosadmin@tims-syncosync:~ $ sudo -v DEBUG -c
[04-12 10:34:49.06] [          soscore] [         remotehost:67  ] [D] keyfile: /etc/syncosync/sshkeys/syncosync
[04-12 10:34:49.17] [          soscore] [         remotehost:95  ] [E] socket error: [Errno 13] Permission denied
RemoteUpStatus.NO_REPLY : Remote host is not reachable (this is no reply on this port from this host) , uuid:

So indeed not reachable - but why? :man_shrugging:t2: Looks like some parsing is going wrong!?

With the --get option I see that the settings are correct. I wanted to play with the --other option but do not know how to pass the json configuration to it?

I sent you the address by PM so you can test with the --other option yourself what is going wrong there?

Ok, this was a genuine bug where the connection check tried to connect to the buddy box via IPv6 while everything else goes via IPv4. Stevie provided me with an ad-hoc fix which will make it into the next update. :+1:t2: :slight_smile:

New package is pushed to the repository, so this one is closed :slight_smile: